This project has moved and is read-only. For the latest updates, please go here.

Startup Error

Aug 25, 2015 at 9:39 PM
Hi Guys,

I have just installed the newest version of the PMUConnectionTester; however once I tried to start the application, it popped up an error dialog with the following details: Do you know what am I missing? Thanks!
Frankie

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at ConnectionTester.PMUConnectionTester.Disconnect()
at ConnectionTester.PMUConnectionTester.Shutdown()
at System.Windows.Forms.Form.WmClose(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
Deleted - I assume this is not related.
Sep 1, 2015 at 1:20 PM
What is the version number of the PMU Connection Tester? And this error appears as soon as you launch the application, before the main window appears, correct? Is this a fatal error, or can you use the application after clearing the error?
Sep 2, 2015 at 3:00 AM
Sorry, below is a more detailed description :)

I am running PMU Connection Tester v. 4.5.5.0 on Windows 7. After the splash screen, a dialog popped up with a title "Microsoft .NET Framework" and message "Unhandled exception has occurred in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will close immediately." If I click continue, the application UI will appear; however, the Protocol list is empty and the application is essentially unusable. I have Microsoft .NET Framework 4 Multi-Targeting Pack and Microsoft .NET Framework 4.5.2. Maybe something went wrong with my .NET Framework?

Below is in the details section - I just realized that this time the error message is different...

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.Xml.XmlException: Root element is missing.
at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo(String res)
at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
at System.Xml.XmlDocument.Load(XmlReader reader)
at System.Xml.XmlDocument.Load(String filename)
at GSF.Configuration.ConfigurationFile.UserConfigurationFile..ctor()
at GSF.Configuration.ConfigurationFile..ctor(String configFilePath)
at GSF.Configuration.ConfigurationFile.<Open>b__0(String path)
at System.Collections.Concurrent.ConcurrentDictionary2.GetOrAdd(TKey key, Func2 valueFactory)
at GSF.Configuration.ConfigurationFile.Open(String configFilePath)
at ConnectionTester.ApplicationSettings..ctor()
at ConnectionTester.PMUConnectionTester.PMUConnectionTester_Load(Object sender, EventArgs e)
at System.EventHandler.Invoke(Object sender, EventArgs e)
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
...
Apr 8, 2016 at 4:09 PM
Thanks Stephen for solving my problem, here is the solution:

Delete the user-specific config file in “%appdata%\Grid Protection Alliance\PMUConnectionTester\Settings.xml”.